General Discussion:

Lilacs


Messages posted to thread:

From:Date:Zone:
Martha10-Jun-08 09:10 AM EST 5a   
10-Jun-08 06:58 PM EST   
11-Jun-08 09:37 AM EST   
mnelso@ns.sympatico.ca14-Jun-08 04:30 PM EST 3b   


Subject: Lilacs
From: Martha (tennismartha@aol.com)
Zone: 5a
Date: 10-Jun-08 09:10 AM EST

I have a dwarf Princess Kim lilac - 2 years old - it bloomed wonderfully last year and there are no blooms at all this year. I suspect I may have pruned it improperly last summer, but perhaps they bloom every other year?

I would appreciate comments. Thanks


Subject: RE: Lilacs
From:
Zone:
Date: 10-Jun-08 06:58 PM EST

Maybe you did over-prune, but this happened to my lilac last year, and I had not pruned it at all. This year it is fine. Weather conditions, perhaps?


Subject: RE: Lilacs
From: (tennismartha@aol.com)
Zone:
Date: 11-Jun-08 09:37 AM EST

Thank you for your comments. Makes me feel better! It sure looks healthy otherwise.


Subject: RE: Lilacs
From: mnelso@ns.sympatico.ca
Zone: 3b
Date: 14-Jun-08 04:30 PM EST

I took leaf cuttings of my Empire Lilac last year....over wintered them in the pots and this spring they are growing beautifully...two of them are setting flowers. Isn't that unusual for a cutting? Is it a false blossom? Should I do anything about it? Thank you for any advice you can give me.


In order to post the forum, you must register to the site.
To register, click here.

If you have already registered, you must log in.
  • New Eden
  • Kids Garden
  • Plant a Row Grow a Row